BDU:2015-00642: Уязвимость программного обеспечения OpenSSL, позволяющая удаленному злоумышленнику нарушить конфиденциальность защищаемой информации

Описание уязвимости Уязвимость существует в протоколе SSL для OpenSSL из-за использования недетерминированного заполнения для CBC-шифрования (сцепление блоков шифротекста). Эксплуатация данной уязвимости позволяет злоумышленнику, действующему по принципу "человек посередине", получить незашифрованные данные, используя атаку с предсказанием заполнения, т. н. атаку POODLE ("пудель").
Вендор OpenSSL Software Foundation
Наименование ПО OpenSSL
Версия ПО
  • от 0.9.8 до 0.9.8.zc
  • от 1.0.0 до 1.0.0o
  • от 1.0.1 до 1.0.1j
Тип ПО Программное средство защиты
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Данные уточняются
Идентификатор типа ошибки
    Класс уязвимости Данные уточняются
    Дата выявления 15.10.2014
    Базовый вектор уязвимости
    Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
    Возможные меры по устранению уязвимости
    Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
    http://www.openssl.org/
    Статус уязвимости Потенциальная уязвимость
    Наличие эксплойта Данные уточняются
    Способ эксплуатации Данные уточняются
    Способ устранения Данные уточняются
    Информация об устранении Информация об устранении отсутствует
    Ссылки на источники
    Идентификаторы других систем описаний уязвимостей
    Прочая информация Данные уточняются
    Последние изменения