BDU:2015-00396: Уязвимость программного обеспечения Apache HTTP Server, позволяющая удаленному злоумышленнику нарушить конфиденциальность, целостность и доступность защищаемой информации

Описание уязвимости Состояние гонки в модуле mod_status в Apache HTTP Server позволяет злоумышленникам, действующим удаленно, вызвать отказ в обслуживании (переполнение буфера в динамической памяти), получить доступ к конфиденциальной информации или выполнить произвольный код при помощи специально сформированного запроса, который вызывает некорректную обработку информационной таблицы (scoreboard) в рамках функции status_handler в modules/generators/mod_status.c и функции lua_ap_scoreboard_worker в modules/lua/lua_request.c.
Вендор Apache Software Foundation
Наименование ПО Apache HTTP Server
Версия ПО
  • от 2.4.0 до 2.4.10
Тип ПО Сетевое программное средство
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Одновременное выполнение с использованием общего ресурса с неправильной синхронизацией («Ситуация гонки»)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 20.07.2014
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Возможные меры по устранению уязвимости
Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
http://www.apache.org/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование сроками и состоянием
Способ устранения Данные уточняются
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения